Re: [PATCH 2/5] kernel: add a helper to get an owning user namespace for a namespace

From: W. Trevor King
Date: Sun Jul 24 2016 - 12:57:26 EST


On Thu, Jul 14, 2016 at 07:12:19PM -0700, Andrey Vagin wrote:
> +struct ns_common *ns_get_owner(struct ns_common *ns)
> +{
> + â
> + return &get_user_ns(user_ns)->ns;
> +}

Is there a reason to return the generic âstruct ns_common *â here
instead of âstruct user_namespace *â? The current use case doesn't
need access to the additional information, but future ng_get_owner
callers might, and we know the returned namespace (if any) will be a
user namespace.

Cheers,
Trevor

--
This email may be signed or encrypted with GnuPG (http://www.gnupg.org).
For more information, see http://en.wikipedia.org/wiki/Pretty_Good_Privacy

Attachment: signature.asc
Description: OpenPGP digital signature