Re: [RFC 0/4] tools lib traceevent: Install fixes

From: Steven Rostedt
Date: Tue Aug 02 2016 - 09:50:27 EST


On Tue, 2 Aug 2016 11:31:34 +0200
Jiri Olsa <jolsa@xxxxxxxxxx> wrote:

> On Tue, Aug 02, 2016 at 12:10:55PM +0900, Namhyung Kim wrote:
> > On Mon, Aug 01, 2016 at 07:41:28PM +0200, Jiri Olsa wrote:
> > > hi,
> > > sending traceevent changes to make this lib installable
> > > under rpm spec.
> > >
> > > Basically adding support to:
> > > - install header files
> > > - install version links
> > >
> > > Having this patchset applied over the fedora source,
> > > I could built following rpms:
> > >
> > > kernel-tools-libs
> > > kernel-tools-libs-devel
> > >
> > > with added libtraceevent stuff:
> > >
> > > $ rpm -ql kernel-tools-libs
> > > /usr/lib64/libcpupower.so.0
> > > /usr/lib64/libcpupower.so.0.0.0
> > > /usr/lib64/libtraceevent.so.1
> > > /usr/lib64/libtraceevent.so.1.1.0
> > >
> > > $ rpm -ql kernel-tools-libs-devel
> > > /usr/include/cpufreq.h
> > > /usr/include/traceevent
> > > /usr/include/traceevent/event-parse.h
> > > /usr/include/traceevent/event-utils.h
> > > /usr/include/traceevent/kbuffer.h
> > > /usr/lib64/libcpupower.so
> > > /usr/lib64/libtraceevent.a
> > > /usr/lib64/libtraceevent.so
> > >
> > > and could build following ex.c outside the kernel tree:
> > >
> > > $ cat ex.c
> > > #include <traceevent/event-parse.h>
> > >
> > > int main(void)
> > > {
> > > struct pevent *pevent = pevent_alloc();
> > > printf("krava %p\n", pevent);
> > > return 0;
> > > }
> > > $ gcc -o ex ex.c -ltraceevent -ldl
> > > $ ./ex
> > > krava 0x10c6010
> > > $
> >
> > On my system, building ex.c with libtraceevent failed:
> >
> > $ gcc -I ~/.local/include/ ex.c -L ~/.local/lib64 -ltraceevent -ldl
> > /home/namhyung/.local/lib64/libtraceevent.so: undefined reference to `str_error_r'
> > collect2: error: ld returned 1 exit status
> >
> >
> > Also I think it'd be better for libtraceevent has dependency to libdl
> > explicitly so that we can get rid of -ldl at the end.
>
> agreed, I'll queue your patch if v2 is needed
>

BTW, before we start making this ready for their own libraries, I'd
like to make some changes with the naming convention. Mainly with
event_format and format_field.

Perhaps we should change them to pevent_event and pevent_field?

-- Steve