Re: [PATCH v5] devicetree: bindings: uart: Add new compatible string for ZynqMP
From: Rob Herring
Date: Mon Oct 03 2016 - 14:42:41 EST
On Mon, Sep 26, 2016 at 07:36:41PM +0530, Nava kishore Manne wrote:
> From: Nava kishore Manne <nava.manne@xxxxxxxxxx>
> This patch Adds the new compatible string for ZynqMP SoC.
> Signed-off-by: Nava kishore Manne <navam@xxxxxxxxxx>
> Changes for v5:
> -Fixed some minor comments.
Not a useful changelog. The point of these comments is to remind the
reviewers of what they commented on.
> Changes for v4:
> -Modified the ChangeLog comment.
> Changes for v3:
> -Added changeLog comment.
> Changes for v2:
> Documentation/devicetree/bindings/serial/cdns,uart.txt | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
> diff --git a/Documentation/devicetree/bindings/serial/cdns,uart.txt b/Documentation/devicetree/bindings/serial/cdns,uart.txt
> index a3eb154..30c885c 100644
> --- a/Documentation/devicetree/bindings/serial/cdns,uart.txt
> +++ b/Documentation/devicetree/bindings/serial/cdns,uart.txt
> @@ -1,7 +1,9 @@
> Binding for Cadence UART Controller
> Required properties:
> -- compatible : should be "cdns,uart-r1p8", or "xlnx,xuartps"
> +- compatible :
> + Use "cdns,uart-r1p8", or "xlnx,xuartps" for Zynq-7xxx SoC.
This is still not right. It was wrong before, but you are touching it so
make it right.
OR doesn't match the dts files. It is AND and the opposite order.
xlnx,xuartps wasn't the best naming, but it's in use so we'll have to
live with it for zynq-7xxx.
> + Use "cdns,uart-r1p12" for Zynq Ultrascale+ MPSoC.
What I meant here was this should have something like "xlnx,mpsoc-uart"
as the first compatible with "cdns,uart-r1p12" as the second. Not sure
if "mpsoc" is the best name here.