RE: Re: [PATCH v2 2/5] ramoops: introduce generic init/free functions for prz
From: åæäæ / IWAMATSUïNOBUHIRO
Date: Wed Oct 05 2016 - 00:43:18 EST
Thanks for youre review.
> -----Original Message-----
> From: keescook@xxxxxxxxxx [mailto:keescook@xxxxxxxxxx] On Behalf Of Kees
> Sent: Friday, September 09, 2016 6:23 AM
> To: åæäæ / IWAMATSUïNOBUHIRO
> Cc: Anton Vorontsov; Colin Cross; Tony Luck; LKML; Hiraku Toyooka; Mark
> Salyzyn; éåèå / AGUCHIïSEIJI
> Subject: [!]Re: [PATCH v2 2/5] ramoops: introduce generic init/free
> functions for prz
> On Sun, Jul 24, 2016 at 8:56 PM, Nobuhiro Iwamatsu
> <nobuhiro.iwamatsu.kw@xxxxxxxxxxx> wrote:
> > From: Hiraku Toyooka <hiraku.toyooka.gu@xxxxxxxxxxx>
> > We modifies initialization and freeing code for prz for generic usage.
> Sorry for the delay in getting to this review, I've been catching up on
> pstore finally. :)
> > This change
> > * add generic function __ramoops_init_prz() to reduce redundancy
> > between ramoops_init_prz() and ramoops_init_przs().
> Can you split this into a separate patch?
OK, I will do.
> > * rename 'przs' member in struct ramoops_context to 'dprzs' so that
> > it stands for 'dump przs'.
> > * rename ramoops_init_prz() to ramoops_init_dprzs().
> And also these two into a separate patch, since it's just a renaming.
> And could you add comments for all the przs, it's getting harder to read
> these since they're just single-letter names. :)
> > * change parameter of ramoops_free_przs() from struct ramoops_context
> > into struct persistent_ram_zone * in order to make it available for
> > all prz array.
> I *think* this should be with the first change, so splitting this email's
> patch into two patches would make review easier (i.e. first do renamings,
> then make functional changes).
OK, I will do too.
> > Signed-off-by: Hiraku Toyooka <hiraku.toyooka.gu@xxxxxxxxxxx>
> > Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.kw@xxxxxxxxxxx>
> > Cc: Mark Salyzyn <salyzyn@xxxxxxxxxxx>
> > Cc: Seiji Aguchi <seiji.aguchi.tr@xxxxxxxxxxx>
> Kees Cook
> Nexus Security