Re: [PATCH 17/34] [media] DaVinci-VPFE-Capture: Improve another size determination in vpfe_enum_input()

From: SF Markus Elfring
Date: Thu Nov 03 2016 - 17:06:55 EST


>> @@ -1091,7 +1091,7 @@ static int vpfe_enum_input(struct file *file, void *priv,
>> return -EINVAL;
>> }
>> sdinfo = &vpfe_dev->cfg->sub_devs[subdev];
>> - memcpy(inp, &sdinfo->inputs[index], sizeof(struct v4l2_input));
>> + memcpy(inp, &sdinfo->inputs[index], sizeof(*inp));
>
> If I am not mistaken this can be written as:
>
> *inp = sdinfo->inputs[index];
>
> Much better.

At which position would you like to integrate a second approach for such a change
from this patch series?

* Do you expect me to send a "V2" for the whole series?

* Will an update step be appropriate if I would rebase it on other
recently accepted suggestions?

Regards,
Markus