Re: [kernel-hardening] Re: [RFC v4 PATCH 00/13] HARDENED_ATOMIC

From: Mark Rutland
Date: Fri Nov 11 2016 - 07:42:10 EST


On Fri, Nov 11, 2016 at 01:29:21AM +0100, Colin Vidal wrote:
> On Fri, 2016-11-11 at 00:57 +0100, Peter Zijlstra wrote:
> > On Thu, Nov 10, 2016 at 03:15:44PM -0800, Kees Cook wrote:
> > > On Thu, Nov 10, 2016 at 2:27 PM, Greg KH <gregkh@xxxxxxxxxxxxxxxxxxx> wrote:
> > > > On Thu, Nov 10, 2016 at 10:13:10PM +0100, Peter Zijlstra wrote:

> I wonder if we didn't make a confusion between naming and
> specifications. I have thought about Kees idea and what you're saying:
>
> - The name "atomic_t" name didn't tell anything about if the variable
> Â can wrap or not. It just tells there is no race condition on
> Â concurrent access, nothing else, and users are well with that. OK
> Â then, we don't modify atomic_t, it makes sense.
>
> - Hence, let's say a new type "refcount_t". It names exactly what we
> Â try to protect in this patch set. A much more simpler interface than
> Â atomic_t would be needed, and it protects on race condition and
> Â overflows (precisely what is expected of a counter reference). Not
> Â an opt-in solution, but it is much less invasive since we "just"
> Â have to modify the kref implementation and some vfs reference
> Â counters.
>
> That didn't tell us how actually implements refcount_t: reuse some
> atomic_t code or not (it would be simpler anyways, since we don't have
> to implement the whole atomic_t interface). Still, this is another
> problem.
>
> Sounds better?

Regardless of atomic_t semantics, a refcount_t would be far more obvious
to developers than atomic_t and/or kref, and better documents the intent
of code using it.

We'd still see abuse of atomic_t (and so this won't solve the problems
Kees mentioned), but even as something orthogonal I think that would
make sense to have.

Thanks,
Mark.