Re: [PATCH v3 05/46] perf/x86/intel/cmt: add per-package locks
From: Thomas Gleixner
Date: Wed Nov 16 2016 - 14:03:34 EST
On Mon, 14 Nov 2016, David Carrillo-Cisneros wrote:
> > Also, "monr" is a horribly 'word'.
> What makes it so bad? (honest question) . Some alternatives:
> - res_mon, resm, rmon (Resource Monitor)
> - rmnode, rnode, rmon_node (Resource Monitoring node, similar to
> Resource Monitor ID, but to reflect that it's a node in a
> - rdt_mon, rdtm (something with RDT + Monitoring)
> - ment, rdt_ment (Monitoring Entity)
> Other suggestions?
The naming is the least of my worries right now. Before you start to rework
the series can we please get the information about:
- what you want to achieve and why
- the design of your approach
so we can avoid staring at another series of 40+ patches just to figure out
that something is wrong at the conceptual level?
We sort out the naming convention once we are done with the above.