Re: [tip:timers/core] ptp_clock: Allow for it to be optional

From: Nicolas Pitre
Date: Thu Nov 17 2016 - 19:48:09 EST

On Thu, 17 Nov 2016, Arnd Bergmann wrote:

> Just for reference to anyone looking for the failure:
> drivers/net/ethernet/amd/Kconfig:183: syntax error
> drivers/net/ethernet/amd/Kconfig:182: unknown option "imply"
> drivers/net/ethernet/adi/Kconfig:62: syntax error
> drivers/net/ethernet/adi/Kconfig:61: unknown option "imply"
> drivers/net/ethernet/broadcom/Kconfig:114: syntax error
> drivers/net/ethernet/broadcom/Kconfig:113: unknown option "imply"
> drivers/net/ethernet/broadcom/Kconfig:124: syntax error
> drivers/net/ethernet/broadcom/Kconfig:123: unknown option "imply"
> drivers/net/ethernet/cavium/Kconfig:57: syntax error
> drivers/net/ethernet/cavium/Kconfig:56: unknown option "imply"
> drivers/net/ethernet/freescale/Kconfig:29: syntax error
> drivers/net/ethernet/freescale/Kconfig:28: unknown option "imply"
> drivers/net/ethernet/intel/Kconfig:62: syntax error
> drivers/net/ethernet/intel/Kconfig:61: unknown option "imply"
> drivers/net/ethernet/intel/Kconfig:87: syntax error
> drivers/net/ethernet/intel/Kconfig:86: unknown option "imply"
> drivers/net/ethernet/intel/Kconfig:160: syntax error
> drivers/net/ethernet/intel/Kconfig:159: unknown option "imply"
> drivers/net/ethernet/intel/Kconfig:217: syntax error
> drivers/net/ethernet/intel/Kconfig:216: unknown option "imply"
> drivers/net/ethernet/intel/Kconfig:268: syntax error
> drivers/net/ethernet/intel/Kconfig:267: unknown option "imply"
> drivers/net/ethernet/mellanox/mlx4/Kconfig:11: syntax error
> drivers/net/ethernet/mellanox/mlx4/Kconfig:10: unknown option "imply"
> drivers/net/ethernet/mellanox/mlx5/core/Kconfig:18: syntax error
> drivers/net/ethernet/mellanox/mlx5/core/Kconfig:17: unknown option "imply"
> drivers/net/ethernet/renesas/Kconfig:41: syntax error
> drivers/net/ethernet/renesas/Kconfig:40: unknown option "imply"
> drivers/net/ethernet/samsung/Kconfig:25: syntax error
> drivers/net/ethernet/samsung/Kconfig:24: unknown option "imply"
> drivers/net/ethernet/sfc/Kconfig:9: syntax error
> drivers/net/ethernet/sfc/Kconfig:8: unknown option "imply"
> drivers/net/ethernet/stmicro/stmmac/Kconfig:8: syntax error
> drivers/net/ethernet/stmicro/stmmac/Kconfig:7: unknown option "imply"
> drivers/net/ethernet/ti/Kconfig:80: syntax error
> drivers/net/ethernet/ti/Kconfig:79: unknown option "imply"
> drivers/net/ethernet/tile/Kconfig:13: syntax error
> drivers/net/ethernet/tile/Kconfig:12: unknown option "imply"
> drivers/ptp/Kconfig:80: syntax error
> drivers/ptp/Kconfig:79: unknown option "imply"
> It was introduced in linux-next today, but it only happens if you
> don't do a 'make clean' or 'make mrproper'. Apparently patch 1
> of the series changes kconfig but that change does not trigger
> a rebuild of the kconfig binary for me. After removing kconfig
> from the object directory, it works again.

That's odd. If I do a git checkout from linux-next of a commit before
this series, then "make oldconfig", and then checkout of master and
"make oldconfig again, in both cases I always get:

$ make oldconfig
HOSTCC scripts/kconfig/conf.o
SHIPPED scripts/kconfig/
SHIPPED scripts/kconfig/zconf.hash.c
HOSTCC scripts/kconfig/
HOSTLD scripts/kconfig/conf
scripts/kconfig/conf --oldconfig Kconfig

And obviously no errors.

> I also ran into a problem with CONFIG_TIMERFD enabled but
> CONFIG_POSIX_TIMERS turned off. This could be related to some
> of my own patches though, haven't tried if that happens
> with just your patches applied.

Tried that combination in my checkout of linux-next, and once again no
build errors here.