Re: [PATCH v12 2/7] x86/arch_prctl/64: Rename do_arch_prctl to do_arch_prctl_64
From: Ingo Molnar
Date: Fri Nov 18 2016 - 03:16:56 EST
* Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> On Fri, 18 Nov 2016, Ingo Molnar wrote:
> > * Kyle Huey <me@xxxxxxxxxxxx> wrote:
> > > In order to introduce new arch_prctls that are not 64 bit only, rename the
> > > existing 64 bit implementation to do_arch_prctl_64(). Also rename the second
> > > argument to arch_prctl(), which will no longer always be an address.
> > > #ifdef CONFIG_X86_64
> > > void entry_SYSCALL_64(void);
> > > +long do_arch_prctl_64(struct task_struct *task, int code, unsigned long arg2);
> > > #endif
> > Could you please also rename the weirdly named 'code' argument to 'option',
> > to be in line with the existing sys_prctl() interface nomenclature?
> I'll fix that up when picking up the series. No need for another iteration, ok?
I think the main patch needs a bit of conceptual work still:
- simpler ABI
- better exec() behavior
- simpler, better, faster implementation for the MSR writes
... see the mail I just wrote.