Re: [PATCH v5] USB hub_probe: rework ugly goto-into-compound-statement

From: Eugene Korenevsky
Date: Sat Nov 19 2016 - 01:41:33 EST


> Ok, I'm going to be really pedantic here and ask that you spell this
> last statement out:
> if (usb...)
> return true;
> return false;


>
> Also, the comment should say:
> /* If the first endpoint is not interrupt IN, we... */
>

It's better to inverse the condition and return false:

```
if (!usb...)
return false;
return true;
```

This is exactly what is said in the comment ("If the first endpoint...
we'd better punt!"). And does not break the composition of the entire
function (all `if` bodies return false, last statement is `return
true`).

--
Eugene