Re: [PATCH 1/4] time: alarmtimer: Add the trcepoints for alarmtimer
From: Baolin Wang
Date: Mon Nov 21 2016 - 04:02:25 EST
On 21 November 2016 at 16:56, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> On Mon, 21 Nov 2016, Baolin Wang wrote:
>> On 21 November 2016 at 16:13, Ingo Molnar <mingo@xxxxxxxxxx> wrote:
>> > Hm, there's a weirdness here: if freezer_delta != 0 when alarmtimer_suspend() is
>> > called then type might be '0', although it's not alarm_bases this value is
>> > picked up from.
>> > Wouldn't it be better to initialize 'type' to -1 instead? (And rename it to
>> > min_type or so.)
>> Make sense. I will send out new patch to fix this. Thanks for your comments.
> Can you please fix the subject line while at it? 'trcepoints' does not look right
Sorry for mistake, I will fix that. Thanks.