Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits

From: Marcin Nowakowski
Date: Fri Dec 09 2016 - 09:04:37 EST

On 09.12.2016 15:03, Steven Rostedt wrote:
On Fri, 9 Dec 2016 09:00:52 -0500
Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

On Fri, 9 Dec 2016 13:25:51 +0100
Marcin Nowakowski <marcin.nowakowski@xxxxxxxxxx> wrote:

The number of probe hits is stored in a percpu variable and therefore
can't be read directly. Add a helper method trace_kprobe_nhit() that
performs the required calculation.

Can you please add the "why?" to this change log. Who needs this
functionality, and why?

I should have specified, even if the next patch uses the functionality,
each patch's change log should stand on its own. In the future, when
people do git blame, they wont be seeing patch series. They will only
see the change log of the one change.

Sure, I will send an updated version with a better changelog.