Re: [PATCH] ACPI: small formatting fixes

From: Pavel Machek
Date: Mon Dec 12 2016 - 17:22:23 EST


On Mon 2016-12-12 10:39:15, Joe Perches wrote:
> On Mon, 2016-12-12 at 09:56 -0800, Nick Desaulniers wrote:
> > A quick cleanup that passes scripts/checkpatch.pl -f <file>.
>
> You might use the --strict option for acpi files.

Please... don't encourage people more, we have enough cleanup patches
as is.

> > diff --git a/arch/x86/kernel/acpi/cstate.c b/arch/x86/kernel/acpi/cstate.c
> []
> > @@ -103,9 +103,8 @@ static long acpi_processor_ffh_cstate_probe_cpu(void *_cx)
> >  
> >         if (!mwait_supported[cstate_type]) {
> >                 mwait_supported[cstate_type] = 1;
> > -               printk(KERN_DEBUG
> > -                       "Monitor-Mwait will be used to enter C-%d "
> > -                       "state\n", cx->type);
> > +               pr_debug("Monitor-Mwait will be used to enter C-%d state\n",
> > +                               cx->type);
>
> It's generally better not to convert
> these printk(KERN_DEBUG uses.
>
> There are behavior differences between
> printk(KERN_DEBUG ...);
> and
> pr_debug(...);
>
> The first will always be emitted as long
> as the console level is appropriate.
>
> The second depends on a #define DEBUG
> before it gets emitted or a kernel
> with CONFIG_DYNAMIC_DEBUG enabled and
> this entry specifically enabled in the
> control file.

Hmm. Perhaps pr_debug should be called pr_c_debug() or something? This
is rather nice trap.

Anyway with that fixed,

Acked-by: Pavel Machek <pavel@xxxxxx>

--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Attachment: signature.asc
Description: Digital signature