[PATCH] 9p: safer definition of P9_NOTAG and P9_NOFID

From: Greg Kurz
Date: Wed Dec 14 2016 - 03:20:54 EST


Both defines should at least have enclosing parenthesis to be usable in
any syntactical situation. This is the case of U16_MAX and U32_MAX, so
let's use them.

This patch is just cleanup, it doesn't change any behaviour with the current
code.

Signed-off-by: Greg Kurz <groug@xxxxxxxx>
---
include/net/9p/9p.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/net/9p/9p.h b/include/net/9p/9p.h
index 27dfe85772b1..5c80d98126b3 100644
--- a/include/net/9p/9p.h
+++ b/include/net/9p/9p.h
@@ -332,8 +332,8 @@ enum p9_qid_t {
};

/* 9P Magic Numbers */
-#define P9_NOTAG (u16)(~0)
-#define P9_NOFID (u32)(~0)
+#define P9_NOTAG U16_MAX
+#define P9_NOFID U32_MAX
#define P9_MAXWELEM 16

/* ample room for Twrite/Rread header */