Re: [PATCH 3/7] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set()
From: Pali Rohár
Date: Thu Dec 15 2016 - 10:44:37 EST
On Thu Dec 15 15:46:28 2016 MichaÅ KÄpieÅ <kernel@xxxxxxxxxx> wrote:
> > On Thursday 08 December 2016 13:36:14 MichaÅ KÄpieÅ wrote:
> > > --- a/sound/pci/hda/dell_wmi_helper.c
> > > +++ b/sound/pci/hda/dell_wmi_helper.c
> > > @@ -6,7 +6,7 @@
> > > #include <linux/dell-led.h>
> > >
> > > static int dell_led_value;
> > > -static int (*dell_led_set_func)(int, int);
> > > +static int (*dell_led_set_func)(int);
> > Suggestion: what about changing name to dell_micmute_led_set_func to
> > match real function name which is used after this patch?
> While I like the idea itself, implementing it will double the number of
> lines that this patch changes (6 vs. 12), arguably making its intention
If some patch makes final result of code better then metric number of lines is not priority.
> less clear.Â Please let me know if you would really like this to happen
> (perhaps as a separate patch?), otherwise I will skip this idea in v2.
> Best regards,
> MichaÅ KÄpieÅ
If it will be in this or another following patch... I dot care. But this is sound subsystem, so sound maintainers need to decide what they prefer.