Re: [PATCH 11/19] staging: iio: isl29028: made column alignment in isl29028_channels consistent

From: Jonathan Cameron
Date: Sun Jan 08 2017 - 04:45:04 EST


On 04/12/16 02:19, Brian Masney wrote:
> The three info_mask_separate members OR several BIT(xxx) fields
> together. This patch changes the column alignment of these fields to be
> aligned at the same column to improve the overall code readability. It
> also moves the { for the next channel to the next line to improve code
> readability.
Skip the bracket change - to my mind it doesn't improve readability.
I mostly don't care which form is used on these (others are fussier) but
changing it from the one I slightly prefer to the one I dislike
is a step too far ;)

Jonathan

>
> Signed-off-by: Brian Masney <masneyb@xxxxxxxxxxxxx>
> ---
> drivers/staging/iio/light/isl29028.c | 10 ++++++----
> 1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/iio/light/isl29028.c b/drivers/staging/iio/light/isl29028.c
> index 0e727ba..218d165 100644
> --- a/drivers/staging/iio/light/isl29028.c
> +++ b/drivers/staging/iio/light/isl29028.c
> @@ -419,14 +419,16 @@ static const struct iio_chan_spec isl29028_channels[] = {
> {
> .type = IIO_LIGHT,
> .info_mask_separate = BIT(IIO_CHAN_INFO_PROCESSED) |
> - BIT(IIO_CHAN_INFO_SCALE),
> - }, {
> + BIT(IIO_CHAN_INFO_SCALE),
> + },
> + {
> .type = IIO_INTENSITY,
> .info_mask_separate = BIT(IIO_CHAN_INFO_RAW),
> - }, {
> + },
> + {
> .type = IIO_PROXIMITY,
> .info_mask_separate = BIT(IIO_CHAN_INFO_RAW) |
> - BIT(IIO_CHAN_INFO_SAMP_FREQ),
> + BIT(IIO_CHAN_INFO_SAMP_FREQ),
> }
> };
>
>