Re: [PATCH net-next v2 05/10] drivers: base: Add device_find_class()

From: David Miller
Date: Thu Jan 12 2017 - 16:21:43 EST


From: Florian Fainelli <f.fainelli@xxxxxxxxx>
Date: Wed, 11 Jan 2017 19:41:16 -0800

> Add a helper function to lookup a device reference given a class name.
> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
> make it more generic.
>
> Signed-off-by: Florian Fainelli <f.fainelli@xxxxxxxxx>
> ---
> drivers/base/core.c | 19 +++++++++++++++++++
> include/linux/device.h | 1 +
> 2 files changed, 20 insertions(+)
>
> diff --git a/drivers/base/core.c b/drivers/base/core.c
> index 020ea7f05520..3dd6047c10d8 100644
> --- a/drivers/base/core.c
> +++ b/drivers/base/core.c
> @@ -2065,6 +2065,25 @@ struct device *device_find_child(struct device *parent, void *data,
> }
> EXPORT_SYMBOL_GPL(device_find_child);
>
> +static int dev_is_class(struct device *dev, void *class)

I know you are just moving code, but this class argumnet is a string
and thus should be "char *" or even "const char *".