Re: [PATCH] writeback: use rb_entry()

From: Tejun Heo
Date: Sun Jan 15 2017 - 18:54:43 EST


On Fri, Jan 13, 2017 at 11:17:12PM +0800, Geliang Tang wrote:
> To make the code clearer, use rb_entry() instead of container_of() to
> deal with rbtree.
>
> Signed-off-by: Geliang Tang <geliangtang@xxxxxxxxx>
> ---
> mm/backing-dev.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/backing-dev.c b/mm/backing-dev.c
> index 3bfed5ab..ffb77a1 100644
> --- a/mm/backing-dev.c
> +++ b/mm/backing-dev.c
> @@ -410,8 +410,8 @@ wb_congested_get_create(struct backing_dev_info *bdi, int blkcg_id, gfp_t gfp)
>
> while (*node != NULL) {
> parent = *node;
> - congested = container_of(parent, struct bdi_writeback_congested,
> - rb_node);
> + congested = rb_entry(parent, struct bdi_writeback_congested,
> + rb_node);

I don't get the rb_entry() macro. It's just another name for
container_of(). I have no objection to the patch but this macro is a
bit silly.

Thanks.

--
tejun