[PATCH V3 0/5] PCI: exynos: cleans the minor things

From: Jaehoon Chung
Date: Mon Jan 16 2017 - 01:31:55 EST


Current pci-exynos.c is used for only EXYNOS5440.
It's too complex to support the other Exynos SoCs.
Before supporting the other Exynos SoCs, it needs to clean the codes.

Changelog on V3:
- Splits "PCI: exynos: replace to one register accessor from each accessors"

Changelog on V2:
- Changes the all pointer names as "ep" instead of "exynos_pcie"

Jaehoon Chung (5):
PCI: exynos: Rename all pointer names from "exynos_pcie" to "ep"
PCI: exynos: Replace the *_blk/*_phy/*_elb accessors
PCI: exynos: Remove the unnecessary variables
PCI: exynos: Use the bitops API to operate the bit shifting
PCI: exynos: remove the duplicated codes

drivers/pci/host/pci-exynos.c | 392 +++++++++++++++++++-----------------------
1 file changed, 181 insertions(+), 211 deletions(-)

--
2.10.2