Re: [PATCH] net/mlx4: use rb_entry()

From: Geliang Tang
Date: Sun Jan 22 2017 - 09:42:47 EST


On Sun, Jan 22, 2017 at 09:48:39AM +0200, Leon Romanovsky wrote:
> On Fri, Jan 20, 2017 at 10:36:57PM +0800, Geliang Tang wrote:
> > To make the code clearer, use rb_entry() instead of container_of() to
> > deal with rbtree.
> >
> > Signed-off-by: Geliang Tang <geliangtang@xxxxxxxxx>
> > ---
> > drivers/net/ethernet/mellanox/mlx4/resource_tracker.c | 8 ++++----
> > 1 file changed, 4 insertions(+), 4 deletions(-)
>
> I don't understand completely the rationale behind this conversion.
> rb_entry == container_of, why do we need another name for it?
>

There are several *_entry macros which are defined in kernel data
structures, like list_entry, hlist_entry, rb_entry, etc. Each of them is
just another name for container_of. We use different *_entry so that we
could identify the specific type of data structure that we are dealing
with.

-Geliang