Re: [PATCH 1/7] x86/fpu: Simplify the fpu->last_cpu logic and rename it to fpu->fpregs_cached

From: Rik van Riel
Date: Thu Jan 26 2017 - 09:54:30 EST


On Thu, 2017-01-26 at 12:26 +0100, Ingo Molnar wrote:

> index c56fb57f2991..7eb2f3041fde 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -1253,6 +1253,8 @@ void set_task_cpu(struct task_struct *p,
> unsigned int new_cpu)
> Â p->sched_class->migrate_task_rq(p);
> Â p->se.nr_migrations++;
> Â perf_event_task_migrate(p);
> +
> + arch_task_migrate(p);
> Â }
>

Does it really count as a "simplification" if you add a
scheduler callback?

This code does not seem any easier to understand than
the old code...