Re: [Resend PATCH 2/2] mm/memory_hotplug: set magic number to page->freelsit instead of page->lru.next

From: Yasuaki Ishimatsu
Date: Fri Feb 03 2017 - 16:14:47 EST



TAB was replaced to white spaces. So please apply this one.

---
From: Yasuaki Ishimatsu <isimatu.yasuaki@xxxxxxxxxxxxxx>
Date: Fri, 3 Feb 2017 15:18:03 -0500
Subject: [PATCH] mm/memory_hotplug: Remove unnecessary code from get_page_bootmem()

The following patch is not applied correctly.
http://lkml.kernel.org/r/2c29bd9f-5b67-02d0-18a3-8828e78bbb6f@xxxxxxxxx

So the following unnecessary code still remains.

void get_page_bootmem()
{
...
page->lru.next = (struct list_head *)type;
...

The patch removes this code from get_page_bootmem()
---
mm/memory_hotplug.c | 1 -
1 file changed, 1 deletion(-)

diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c
index 7409f25..d67787d 100644
--- a/mm/memory_hotplug.c
+++ b/mm/memory_hotplug.c
@@ -179,7 +179,6 @@ static void release_memory_resource(struct resource *res)
void get_page_bootmem(unsigned long info, struct page *page,
unsigned long type)
{
- page->lru.next = (struct list_head *)type;
page->freelist = (void *)type;
SetPagePrivate(page);
set_page_private(page, info);
--
1.8.3.1