Re: drivers/net/wireless/broadcom/brcm80211/brcmfmac/debug.c:58:6: error: redefinition of 'brcmf_debugfs_init'

From: Kalle Valo
Date: Thu Feb 16 2017 - 08:19:07 EST

Arend Van Spriel <arend.vanspriel@xxxxxxxxxxxx> writes:

> On 16-2-2017 11:01, Kalle Valo wrote:
>> Arend Van Spriel <arend.vanspriel@xxxxxxxxxxxx> writes:
>>> On 16-2-2017 10:39, RafaÅ MiÅecki wrote:
>>>> On 02/16/2017 10:31 AM, Kalle Valo wrote:
>>>>> (Adding linux-wireless)
>>>>> Arend or RafaÅ, would you be able to look at this build problem? Kbuild
>>>>> found the build errors below, apparently a very old issue. It just
>>>>> blames me now because I moved the driver to a new directory :)
>>> It is a very old issue. The thing is that the issue can not really occur
>>> because we have this:
>>> # common flags
>>> subdir-ccflags-$(CONFIG_BRCMDBG) += -DDEBUG
>>> in drivers/net/wireless/broadcom/brcm80211/Makefile. So no clue what
>>> happens in the "kbuild test robot" scenario.
>> I actually tried to reproduce this with kbuild bot's instructions and
>> was surprised to see that the build worked ok for me. So the issue is
>> not that simple.
> Hi Kalle,
> Here is the old email exchange we had about this [1]. In my opinion this
> is a Kbuild issue that needs to be looked into.
> Regards,
> Arend
> [1]

Heh, I had completely forgotten that we had discussed this before :)

Fengguang and the kbuild bot team, do you have any ideas why only the
bot is seeing this?

Kalle Valo