Re: [RFC PATCH] sched/wait: Introduce new, more compact wait_event*() primitives
From: Ingo Molnar
Date: Wed Mar 08 2017 - 08:10:34 EST
* Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> You can find the latest (WIP, frequently rebased) version in:
> git git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git WIP.sched/core
> The first 10 patches reshape the waitqueue code to be more hackable (to me!),
> because I kept bumping into confusing names all the time, but the real change
> you'd be most interested in is, in an RFC (to be rebased!) form, the following
> 0c32c5717beb sched/wait: Introduce new, more compact wait_event*() primitives
> I've attached that patch below as well.
Note that I rebased it meanwhile so the SHA1's changed. The commit titles should
still be the same though.