Re: [PATCH] powerpc: sysdev: cpm1: Optimise gpio bit calculation

From: Christophe LEROY
Date: Fri Mar 10 2017 - 09:42:05 EST




Le 10/03/2017 à 15:32, Segher Boessenkool a écrit :
On Fri, Mar 10, 2017 at 03:04:48PM +0100, Christophe LEROY wrote:
Le 10/03/2017 à 14:06, Segher Boessenkool a écrit :
On Fri, Mar 10, 2017 at 11:54:19AM +0100, Christophe LEROY wrote:
gpio_get() and gpio_set() are used extensively by some GPIO based
drivers like SPI, NAND, so it may be worth it as it doesn't impair
readability (if anyone prefers, we could write (1 << 31) >> i instead
of 0x80000000 >> i )

1 << 31 is undefined behaviour, of course.


Shall it be 1U << 31 ?

Sure, that works. "1 << (31 - i)" is most readable (but it doesn't yet
generate the code you want).



Euh .... I'm a bit lost. Do you mean the form we have today is the driver is wrong ?


@@ -684,9 +682,7 @@ static int cpm1_gpio32_get(struct gpio_chip *gc, unsigned int gpio)
{
struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
struct cpm_ioport32b __iomem *iop = mm_gc->regs;
- u32 pin_mask;
-
- pin_mask = 1 << (31 - gpio);
+ u32 pin_mask = 0x80000000 >> gpio;

return !!(in_be32(&iop->dat) & pin_mask);
}


Which I thought could also become


@@ -684,9 +682,7 @@ static int cpm1_gpio32_get(struct gpio_chip *gc, unsigned int gpio)
{
struct of_mm_gpio_chip *mm_gc = to_of_mm_gpio_chip(gc);
struct cpm_ioport32b __iomem *iop = mm_gc->regs;
- u32 pin_mask;
-
- pin_mask = 1 << (31 - gpio);
+ u32 pin_mask = (1 << 31) >> gpio;

return !!(in_be32(&iop->dat) & pin_mask);
}


Christophe