Re: [PATCH] serial: tegra: Map the iir register to default defines

From: Olliver Schinagl
Date: Fri Mar 31 2017 - 07:32:59 EST


Hey Shadar,

On 31-03-17 12:42, Shardar Mohammed wrote:
On 31/03/17 11:07, Shardar Mohammed wrote:
Verification failed on Tegra.
Fix here is, IIR should be masked with UART_IIR_MASK after reading the IIR
register as on Tegra bit-6 is used for internal usage to know if FIFO mode is
enabled.
while (1) {
iir = tegra_uart_read(tup, UART_IIR);
+iir &= UART_IIR_MASK;

Per Olliver's original email did you pick up the other patch [0] before applying
this because that does apply the mask. I mentioned to Olliver that this should
really be a series, so it is clear that this patch is dependent upon the other.

For UART_IIR_MASK macro, dependent patch is required if we add this required line.
But here to fix the issue with the current patch above masking step is necessary.

Yeah the other big patch adds this line (and does some other fixes to the tegra driver with regards to the UART_IIR_MASK).

I did not make it a 'set' because the other patch has a big big list of names and touches a lot of serial devices. So both 'groups' would get a lot of noise. I'm sorry if this caused confusion. If you guys prefer, I'll turn it into a set.

Again, sorry for the inconvenience,

Olliver


-----Original Message-----
From: Laxman Dewangan
Sent: Thursday, March 30, 2017 3:48 PM
To: Olliver Schinagl <oliver@xxxxxxxxxxx>; Greg Kroah-Hartman
<gregkh@xxxxxxxxxxxxxxxxxxx>; Jiri Slaby <jslaby@xxxxxxxx>; Stephen
Warren <swarren@xxxxxxxxxxxxx>; Thierry Reding
<thierry.reding@xxxxxxxxx>; Alexandre Courbot <gnurou@xxxxxxxxx>
Cc: linux-serial@xxxxxxxxxxxxxxx; linux-tegra@xxxxxxxxxxxxxxx;
linux-kernel@xxxxxxxxxxxxxxx; Shardar Mohammed
<smohammed@xxxxxxxxxx>
Subject: Re: [PATCH] serial: tegra: Map the iir register to default
defines


On Thursday 30 March 2017 12:18 AM, Olliver Schinagl wrote:
The tegra serial IP seems to be following the common layout and the
interrupt ID's match up nicely. Replace the magic values to match the
common serial_reg defines, with the addition of the Tegra unique End
of Data interrupt.

Signed-off-by: Olliver Schinagl <oliver@xxxxxxxxxxx>
---

Adding Shardar for verifications.

Acked-by: Laxman Dewangan <ldewangan@xxxxxxxxxx>

Furthermore does this ACK imply that you have reviewed the other patch this
one is dependent upon?

Yes dependent change looks fine, but I have not tested it.

Cheers
Jon

[0] http://marc.info/?l=linux-serial&m=149081309627392&w=2

--
nvpublic