Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning

From: Randy Dunlap
Date: Fri Mar 31 2017 - 22:15:13 EST


On 03/31/17 18:59, Chewie Lin wrote:
> Replace string with formatted arguments in the dev_warn() call. It removes
> the checkpatch warning:
>
> WARNING: Prefer using "%s", __func__ to embedded function names
> #417: FILE: main_usb.c:417:
> + "usb_device_reset fail status=%d\n", status);
>
> total: 0 errors, 1 warnings, 1058 lines checked
>
> And after fix:
>
> main_usb.c has no obvious style problems and is ready for submission.
>
> Signed-off-by: Chewie Lin <linsh@xxxxxxxxxxxxxxx>
> ---
> drivers/staging/vt6656/main_usb.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/vt6656/main_usb.c b/drivers/staging/vt6656/main_usb.c
> index 9e074e9..2d9e7af 100644
> --- a/drivers/staging/vt6656/main_usb.c
> +++ b/drivers/staging/vt6656/main_usb.c
> @@ -414,7 +414,7 @@ static void usb_device_reset(struct vnt_private *priv)
> status = usb_reset_device(priv->usb);
> if (status)
> dev_warn(&priv->usb->dev,
> - "usb_device_reset fail status=%d\n", status);
> + "%s=%d\n", "usb_device_reset fail status", status);
> }
>
> static void vnt_free_int_bufs(struct vnt_private *priv)
>

As other people have said:

This function is usb_device_reset(). If that function name string is to be
used in the message, it should be done so by using __func__.
See http://marc.info/?l=linux-driver-devel&m=149095639202492&w=2

Or is the called (failing) function name is to be kept in the message (as it
is currently), then the message should contain "usb_reset_device" instead of
"usb_device_reset". See http://marc.info/?l=linux-driver-devel&m=149098680312723&w=2



--
~Randy