Re: [PATCH 03/16] uuid: rename uuid types

From: Christoph Hellwig
Date: Thu May 11 2017 - 03:59:33 EST


On Wed, May 10, 2017 at 10:15:51PM +0300, Amir Goldstein wrote:
> > +static inline int uuid_cmp(const uuid_t u1, const uuid_t u2)
> > {
> > - return memcmp(&u1, &u2, sizeof(uuid_be));
> > + return memcmp(&u1, &u2, sizeof(uuid_t));
> > }
> >
>
>
> I think we should use this opportunity to change these to (uuid_t *, uuid_t *)
> which is more in line with the rest of the helpers including the new helpers
> hoisted from xfs.

Or just kill them off - uuid/guid_equals is the better interface for all
existing users as far as I can tell. My updated series already kills
off the be/uuid one, the le/guid one will need a bit more work, though.