Re: [PATCH 7/7] DWARF: add the config option

From: H. Peter Anvin
Date: Mon May 22 2017 - 17:20:44 EST

On 05/22/17 04:12, Ingo Molnar wrote:
>> This construct might be useful for other arches, which is why I called
>> it "FP" instead of "BP". But then I ruined that with the last 3 :-)
> Please call it BP - 'FP' can easily be read as floating-point, making it all
> super-confusing. We should use canonical x86 register names and ordering - even
> if not all registers are used straight away.

Seriously, I suspect that at the end of the day we will have reinvented