Re: [PATCH 1/9] mm: introduce kv[mz]alloc helpers

From: Michal Hocko
Date: Fri Jun 02 2017 - 03:29:05 EST


On Fri 02-06-17 07:17:22, Sasha Levin wrote:
> On Mon, Mar 06, 2017 at 11:30:24AM +0100, Michal Hocko wrote:
> > +void *kvmalloc_node(size_t size, gfp_t flags, int node)
> > +{
> > + gfp_t kmalloc_flags = flags;
> > + void *ret;
> > +
> > + /*
> > + * vmalloc uses GFP_KERNEL for some internal allocations (e.g page tables)
> > + * so the given set of flags has to be compatible.
> > + */
> > + WARN_ON_ONCE((flags & GFP_KERNEL) != GFP_KERNEL);
>
> Hm, there are quite a few locations in the kernel that do something like:
>
> __vmalloc(len, GFP_NOFS, PAGE_KERNEL);
>
> According to your patch, vmalloc can't really do GFP_NOFS, right?

Yes. It is quite likely that they will just work because the hardcoded
GFP_KERNEL inside the vmalloc path is in unlikely paths (page table
allocations for example) but yes they are broken. I didn't convert some
places which opencode the kvmalloc with GFP_NOFS because I strongly
_believe_ that the GFP_NOFS should be revisited, checked whether it is
needed, documented if so and then memalloc_nofs__{save,restore} be used
for the scope which is reclaim recursion unsafe. This would turn all
those vmalloc users to the default GFP_KERNEL and still do the right
thing.
--
Michal Hocko
SUSE Labs