Re: [PATCH] percpu_counter: Rename __percpu_counter_add to percpu_counter_add_batch
From: David Sterba
Date: Wed Jun 21 2017 - 08:09:45 EST
On Tue, Jun 20, 2017 at 03:47:59PM -0400, Tejun Heo wrote:
> From 104b4e5139fe384431ac11c3b8a6cf4a529edf4a Mon Sep 17 00:00:00 2001
> From: Nikolay Borisov <nborisov@xxxxxxxx>
> Date: Tue, 20 Jun 2017 21:01:20 +0300
> Currently, percpu_counter_add is a wrapper around __percpu_counter_add
> which is preempt safe due to explicit calls to preempt_disable. Given
> how __ prefix is used in percpu related interfaces, the naming
> unfortunately creates the false sense that __percpu_counter_add is
> less safe than percpu_counter_add. In terms of context-safety,
> they're equivalent. The only difference is that the __ version takes
> a batch parameter.
> Make this a bit more explicit by just renaming __percpu_counter_add to
> This patch doesn't cause any functional changes.
> tj: Minor updates to patch description for clarity. Cosmetic
> indentation updates.
> Signed-off-by: Nikolay Borisov <nborisov@xxxxxxxx>
> Signed-off-by: Tejun Heo <tj@xxxxxxxxxx>
> Cc: Chris Mason <clm@xxxxxx>
> Cc: Josef Bacik <jbacik@xxxxxx>
> Cc: David Sterba <dsterba@xxxxxxxx>
Acked-by: David Sterba <dsterba@xxxxxxxx>