Re: 4.3 serial driver crashes with console shortly after boot

From: Jiri Slaby
Date: Fri Jun 23 2017 - 07:24:06 EST

On 11/11/2015, 05:50 PM, Andi Kleen wrote:
> On Wed, Nov 11, 2015 at 06:14:30AM -0500, Peter Hurley wrote:
>> On 11/10/2015 06:15 PM, Peter Hurley wrote:
>>> On 11/10/2015 05:43 PM, Andi Kleen wrote:
>>>> On Tue, Nov 10, 2015 at 11:39:57PM +0100, Andi Kleen wrote:
>>>>>> I've just tried to reproduce this without success on my current
>>>>>> tree which has some additional patches I just posted this am. They weren't
>>>>>> intended to fix crashes but they directly impact the area of concern. Could
>>>>>> you try these three?
>>>>>> [PATCH v2 2/4] n_tty: Ignore all read data when closing
>>>>>> [PATCH v2 3/4] tty: Abstract and encapsulate tty->closing behavior
>>>>>> [PATCH v2 4/4] tty: Remove drivers' extra tty_ldisc_flush()
>>>>> Applying the three patches fixes the crash.
>>>>> I haven't tried to figure out which one did the trick.
>>>> Actually I was wrong sorry. It still crashes, but now it doesn't
>>>> hang the system anymore.
>>> Argghh.
>>> Can you run the patch below and send me full dmesg (privately if you prefer)?
>> Nevermind. I see how it's happening now; it's being initiated by hangup,
>> not close. FWIW, it's been like that nearly forever; your user-space/tool is
>> triggering this because ECHO is on.
> It's just agetty i believe, but there may be some funkiness going on
> with the terminal server or the cable.
> Thanks. I'll just add a NULL pointer check for now, until you have
> a real patch.

It looks like 4.4 (-stable) still suffers from this. Has this ever been
fixed somehow?

suse labs