Re: [PATCH] printk: Modify operators of printed_len
From: pierre kuo
Date: Fri Jul 07 2017 - 22:50:00 EST
>> > 
>> > > diff --git a/kernel/printk/printk.c b/kernel/printk/printk.c
>> > 
>> > > @@ -1754,7 +1754,7 @@ asmlinkage int vprintk_emit(int facility, int level,
>> > > if (dict)
>> > > lflags |= LOG_PREFIX|LOG_NEWLINE;
>> > >
>> > > - printed_len += log_output(facility, level, lflags, dict, dictlen, text, text_len);
>> > > + printed_len = log_output(facility, level, lflags, dict, dictlen, text, text_len);
>> > If this is appropriate, this should also remove the
>> > initialization of printed_len and perhaps rename it too.
>> I cannot quite understand the reason why need to rename.
>> printed_len seems meet the meaning we expect for here.
> Verbosity. To me, len would be adequate.
> Anyway, the real point was the declaration of printed_len could
> remove the " = 0" as it's now only set once.
Got it and I will resend the patch again.
Appreciate your kind advice.