Re: [PATCH v3 11/49] btrfs: avoid access to .bi_vcnt directly

From: Christoph Hellwig
Date: Thu Aug 10 2017 - 07:30:11 EST


> +static unsigned int get_bio_pages(struct bio *bio)
> +{
> + unsigned i;
> + struct bio_vec *bv;
> +
> + bio_for_each_segment_all(bv, bio, i)
> + ;
> +
> + return i;
> +}

s/get_bio_pages/bio_nr_pages/ ?

Also this seems like a useful helper for bio.h