Re: [PATCH] mfd: rtsx: Add support for RTS5260

From: Greg KH
Date: Fri Sep 22 2017 - 05:54:31 EST


On Fri, Sep 22, 2017 at 05:36:24PM +0800, rui_feng@xxxxxxxxxxxxxx wrote:
> From: rui_feng <rui_feng@xxxxxxxxxxxxxx>
>
> Add support for new chip rts5260.
> In order to support rts5260ïthe definitions of some internal
> registers and workflow have to be modified and are different from its
> predecessors. So we need this patch to ensure RTS5260 can work.
>
> Signed-off-by: Rui Feng <rui_feng@xxxxxxxxxxxxxx>

Nit, this name needs to match your "From:" line. It almost does :)

Why is this a drivers/misc/ driver?

> --- /dev/null
> +++ b/drivers/misc/rts5260.c
> @@ -0,0 +1,590 @@
> +/* Driver for Realtek PCI-Express card reader
> + *
> + * Copyright(c) 2016-2017 Realtek Semiconductor Corp. All rights reserved.
> + *
> + * This program is free software; you can redistribute it and/or modify it
> + * under the terms of the GNU General Public License as published by the
> + * Free Software Foundation; either version 2, or (at your option) any
> + * later version.

Do you really mean "any later version"? (I have to ask...)

> + *
> + * This program is distributed in the hope that it will be useful, but
> + * WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
> + * General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License along
> + * with this program; if not, see <http://www.gnu.org/licenses/>.
> + *
> + * Author:
> + * Steven FENG <steven_feng@xxxxxxxxxxxxxx>
> + * Rui FENG <rui_feng@xxxxxxxxxxxxxx>
> + * Wei WANG <wei_wang@xxxxxxxxxxxxxx>
> + */
> +
> +#include <linux/module.h>
> +#include <linux/delay.h>
> +#include <linux/mfd/rtsx_pci.h>
> +
> +#include "../mfd/rtsx_pcr.h"

That looks "odd" :(

thanks,

greg k-h