Re: [PATCH 0/3] add %pX specifier

From: Joe Perches
Date: Tue Oct 10 2017 - 23:27:27 EST


On Wed, 2017-10-11 at 10:32 +1100, Tobin C. Harding wrote:
> On Tue, Oct 10, 2017 at 04:15:01PM -0700, Linus Torvalds wrote:
> > On Tue, Oct 10, 2017 at 4:09 PM, Tobin C. Harding <me@xxxxxxxx> wrote:
> > >
> > > I did not understand the code (specifically why the right shift of 16 twice?)
> >
> > It's a traditional trick to get the upper 32 bits.
> >
> > So it basically splits the (possibly 64-bit) pointer into the lower 32
> > bits and the upper 32 bits for a hash such as "jhash()" that takes
> > data that is "unsigned int".
> >
> > (NOTE! Using jhash here is not acceptable, since it's not
> > cryptographically safe, but think of it as an example of a hash that
> > takes 32-bit input).
> >
> > Doing ">> 32" is undefined on 32-bit architectures, and wouldn't work.
> >
> > But doing >> 16 >> 16 is a fine way to say "shift right by 32 on a
> > 64-bit architecture" while also being well-defined on a 32-bit one.
> >
> > Linus
>
> Awesome, thanks.

Another way is using the upper_32_bits() macro.
It's perhaps a bit more readable.