Re: [PATCH] drm/amd/display: remove unnecessary cast and use kcalloc instead of kzalloc

From: Alex Deucher
Date: Thu Nov 16 2017 - 16:39:04 EST


On Wed, Nov 15, 2017 at 10:45 AM, Colin King <colin.king@xxxxxxxxxxxxx> wrote:
> From: Colin Ian King <colin.king@xxxxxxxxxxxxx>
>
> Use kcalloc instead of kzalloc and the cast on the return from kzalloc is
> unnecessary and can be removed.
>
> Signed-off-by: Colin Ian King <colin.king@xxxxxxxxxxxxx>

Reviewed and pushed.

Thanks!

Alex

> ---
> drivers/gpu/drm/amd/display/dc/basics/logger.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/display/dc/basics/logger.c b/drivers/gpu/drm/amd/display/dc/basics/logger.c
> index e04e8ecd4874..2ff5b467603d 100644
> --- a/drivers/gpu/drm/amd/display/dc/basics/logger.c
> +++ b/drivers/gpu/drm/amd/display/dc/basics/logger.c
> @@ -70,9 +70,8 @@ static bool construct(struct dc_context *ctx, struct dal_logger *logger,
> {
> /* malloc buffer and init offsets */
> logger->log_buffer_size = DAL_LOGGER_BUFFER_MAX_SIZE;
> - logger->log_buffer = (char *)kzalloc(logger->log_buffer_size * sizeof(char),
> - GFP_KERNEL);
> -
> + logger->log_buffer = kcalloc(logger->log_buffer_size, sizeof(char),
> + GFP_KERNEL);
> if (!logger->log_buffer)
> return false;
>
> --
> 2.14.1
>
> _______________________________________________
> dri-devel mailing list
> dri-devel@xxxxxxxxxxxxxxxxxxxxx
> https://lists.freedesktop.org/mailman/listinfo/dri-devel