Re: [PATCH net-next v1] bpf: Use the IS_FD_ARRAY() macro in map_update_elem()

From: Alexei Starovoitov
Date: Thu Jan 25 2018 - 21:09:34 EST


On Fri, Jan 26, 2018 at 12:54:02AM +0100, Mickaël Salaün wrote:
> Make the code more readable.
>
> Signed-off-by: Mickaël Salaün <mic@xxxxxxxxxxx>
> Cc: Alexei Starovoitov <ast@xxxxxxxxxx>
> Cc: Daniel Borkmann <daniel@xxxxxxxxxxxxx>
> ---
> kernel/bpf/syscall.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
> index 5bdb0cc84ad2..e24aa3241387 100644
> --- a/kernel/bpf/syscall.c
> +++ b/kernel/bpf/syscall.c
> @@ -709,10 +709,7 @@ static int map_update_elem(union bpf_attr *attr)
> err = bpf_percpu_hash_update(map, key, value, attr->flags);
> } else if (map->map_type == BPF_MAP_TYPE_PERCPU_ARRAY) {
> err = bpf_percpu_array_update(map, key, value, attr->flags);
> - } else if (map->map_type == BPF_MAP_TYPE_PERF_EVENT_ARRAY ||
> - map->map_type == BPF_MAP_TYPE_PROG_ARRAY ||
> - map->map_type == BPF_MAP_TYPE_CGROUP_ARRAY ||
> - map->map_type == BPF_MAP_TYPE_ARRAY_OF_MAPS) {
> + } else if (IS_FD_ARRAY(map)) {

Applied to bpf-next, thank you Mickael.