Re: [PATCH v2] reset: add support for non-DT systems

From: Andy Shevchenko
Date: Tue Feb 13 2018 - 14:17:38 EST


On Tue, Feb 13, 2018 at 8:39 PM, Bartosz Golaszewski <brgl@xxxxxxxx> wrote:
> From: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx>
>
> The reset framework only supports device-tree. There are some platforms
> however, which need to use it even in legacy, board-file based mode.
>
> An example of such architecture is the DaVinci family of SoCs which
> supports both device tree and legacy boot modes and we don't want to
> introduce any regressions.
>
> We're currently working on converting the platform from its hand-crafted
> clock API to using the common clock framework. Part of the overhaul will
> be representing the chip's power sleep controller's reset lines using
> the reset framework.
>
> This changeset extends the core reset code with a new field in the
> reset controller struct which contains an array of lookup entries. Each
> entry contains the device name and an additional, optional identifier
> string.
>
> Drivers can register a set of reset lines using this lookup table and
> concerned devices can access them using the regular reset_control API.
>
> This new function is only called as a fallback in case the of_node
> field is NULL and doesn't change anything for current users.
>
> Tested with a dummy reset driver with several lookup entries.
>
> An example lookup table can look like this:
>
> static const struct reset_lookup foobar_reset_lookup[] = {
> [FOO_RESET] = { .dev = "foo", .id = "foo_id" },
> [BAR_RESET] = { .dev = "bar", .id = NULL },
> { }
> };
>
> where FOO_RESET and BAR_RESET will correspond with the id parameters
> of reset callbacks.

> +static struct reset_control *
> +__reset_control_get_from_lookup(struct device *dev, const char *id,
> + bool shared, bool optional)
> +{
> + struct reset_controller_dev *rcdev;
> + const char *dev_id = dev_name(dev);
> + struct reset_control *rstc = NULL;
> + const struct reset_lookup *lookup;
> + int index;
> +
> + mutex_lock(&reset_list_mutex);
> +
> + list_for_each_entry(rcdev, &reset_controller_list, list) {
> + if (!rcdev->lookup)
> + continue;
> +
> + lookup = rcdev->lookup;

> + for (index = 0; lookup->dev; index++, lookup++) {
> + if (strcmp(dev_id, lookup->dev))
> + continue;
> +
> + if ((!id && !lookup->id) ||
> + (id && lookup->id && !strcmp(id, lookup->id))) {
> + rstc = __reset_control_get_internal(rcdev,
> + index, shared);
> + break;
> + }

Wouldn't be slightly more readable

if (id && lookup->id) {
if (strcmp(id, lookup->id))
continue;
} else if (id || lookup->id) {
continue;
}

rstc = __reset_control_get_internal(rcdev, index, shared);
break;

> + }
> + }
> +
> + mutex_unlock(&reset_list_mutex);
> +

> + if (!rstc)
> + return optional ? NULL : ERR_PTR(-ENOENT);

Isn't simpler

if (!optional && !rstc) // or other way around, depending which might
be more offten
return ERR_PTR(...);

> + return rstc;
> +}

--
With Best Regards,
Andy Shevchenko