Re: [PATCH] i40evf: remove redundant array comparisons to 0 checks

From: Joe Perches
Date: Sun Feb 18 2018 - 11:32:01 EST


On Sun, 2018-02-18 at 16:58 +0200, Andy Shevchenko wrote:
> On Fri, Feb 16, 2018 at 6:53 PM, Colin Ian King
> <colin.king@xxxxxxxxxxxxx> wrote:
> > On 16/02/18 16:51, Andy Shevchenko wrote:
> > > On Thu, Feb 15, 2018 at 9:42 PM, Colin King <colin.king@xxxxxxxxxxxxx> wrote:
> > > > + filter->f.mask.tcp_spec.dst_ip[i] |=
> > > > cpu_to_be32(0xffffffff);
> > >
> > > Can it be one line then?
> >
> > I re-adjusted the text because checkpatch was complaining.
> > >
> > > > + filter->f.mask.tcp_spec.src_ip[i] |=
> > > > cpu_to_be32(0xffffffff);
>
> For the rest OK, but for the above two how much over 80 it went if
> would be one line?
> If it 2-3 characters, consider to make it one line. It would increase
> readability.

Another possibility would be to use temporaries for
filter->f.mask.tcp_spec
and
filter->f.data.tcp_spec
as both are used ~10 times in the function