Re: [PATCH v10 1/7] PCI/AER: Rename error recovery to generic pci naming

From: Christoph Hellwig
Date: Thu Feb 22 2018 - 13:34:12 EST


On Thu, Feb 22, 2018 at 09:32:06PM +0530, Oza Pawandeep wrote:
> This patch renames error recovery to generic name with pci prefix
>
> Signed-off-by: Oza Pawandeep <poza@xxxxxxxxxxxxxx>
>
> diff --git a/drivers/pci/pcie/aer/aerdrv_core.c b/drivers/pci/pcie/aer/aerdrv_core.c
> index a4bfea5..306bf2f 100644
> --- a/drivers/pci/pcie/aer/aerdrv_core.c
> +++ b/drivers/pci/pcie/aer/aerdrv_core.c
> @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev)
> }
>
> /**
> - * do_recovery - handle nonfatal/fatal error recovery process
> + * pci_do_recovery - handle nonfatal/fatal error recovery process
> * @dev: pointer to a pci_dev data structure of agent detecting an error
> * @severity: error severity type
> *
> @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev)
> * error detected message to all downstream drivers within a hierarchy in
> * question and return the returned code.
> */
> -static void do_recovery(struct pci_dev *dev, int severity)
> +static void pci_do_recovery(struct pci_dev *dev, int severity)

Maybe pcie_do_recovery?

Otherwise looks fine:

Reviewed-by: Christoph Hellwig <hch@xxxxxx>