Re: [PATCH 01/21] powerpc: Remove warning on array size when empty

From: Segher Boessenkool
Date: Sun Feb 25 2018 - 14:13:33 EST


Hi!

On Sun, Feb 25, 2018 at 06:22:16PM +0100, Mathieu Malaterre wrote:
> When neither CONFIG_ALTIVEC, nor CONFIG_VSX or CONFIG_PPC64 is defined, the
> array feature_properties is defined as an empty array, which in turn
> triggers the following warning (treated as error on W=1):

> - for (i = 0; i < ARRAY_SIZE(feature_properties); ++i, ++fp) {
> + for (; fp != feature_properties + ARRAY_SIZE(feature_properties); ++fp) {

You could just write != instead of < ? Seems more readable.

Maybe something can be done to ARRAY_SIZE to make this not warn.


Segher