[PATCH 0/7] fujitsu-laptop: Consistent naming of constants

From: MichaÅ KÄpieÅ
Date: Tue Feb 27 2018 - 16:17:48 EST


This patch series is an attempt to organize all the named constants used
throughout fujitsu-laptop so that their names more clearly convey their
purpose: a set of prefixes is introduced to "map" constant names to
call_fext_func() parameters.

The chosen constant naming patterns are a compromise between readability
and enabling longer conditional expressions to fit into the 80-character
line length limit. Some changes (like those in patches 4/7 and 5/7) may
be perceived as bikeshedding, so please just think of them as proposals,
not fixes.

Finally, patch 7/7 again [1] proposes a set of helper functions which
seem to be making quite a difference in terms of code readability in
certain places (especially in long conditional expressions). YMMV,
though, feel free to disagree.

This patch series should be applied on top of for-next as it builds on
the previous patch series I submitted.

[1] https://www.spinics.net/lists/platform-driver-x86/msg11633.html

drivers/platform/x86/fujitsu-laptop.c | 228 +++++++++++++++++++---------------
1 file changed, 127 insertions(+), 101 deletions(-)

--
2.16.2