Re: [PATCH v3] cpufreq: schedutil: rate limits for SCHED_DEADLINE

From: Viresh Kumar
Date: Thu Mar 08 2018 - 05:33:14 EST


On 08-03-18, 11:29, Claudio Scordino wrote:
> When the SCHED_DEADLINE scheduling class increases the CPU utilization,
> we should not wait for the rate limit, otherwise we may miss some
> deadline.
>
> Tests using rt-app on Exynos5422 with up to 10 SCHED_DEADLINE tasks have
> shown reductions of even 10% of deadline misses with a negligible
> increase of energy consumption (measured through Baylibre Cape).
>
> Signed-off-by: Claudio Scordino <claudio@xxxxxxxxxxxxxxx>
> CC: Ingo Molnar <mingo@xxxxxxxxxx>
> CC: Patrick Bellasi <patrick.bellasi@xxxxxxx>
> CC: Dietmar Eggemann <dietmar.eggemann@xxxxxxx>
> CC: Morten Rasmussen <morten.rasmussen@xxxxxxx>
> CC: Juri Lelli <juri.lelli@xxxxxxxxxx>
> CC: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> CC: Vincent Guittot <vincent.guittot@xxxxxxxxxx>
> CC: Todd Kjos <tkjos@xxxxxxxxxxx>
> CC: Joel Fernandes <joelaf@xxxxxxxxxx>
> CC: linux-pm@xxxxxxxxxxxxxxx
> CC: linux-kernel@xxxxxxxxxxxxxxx
> ---
> Changes from v2:
> - Rate limit ignored also in case of "fast switch"
> - Specific routine added
> ---
> Changes from v1:
> - Logic moved from sugov_should_update_freq() to
> sugov_update_single()/_shared() to not duplicate data structures
> - Rate limit not ignored in case of "fast switch"
> ---
> kernel/sched/cpufreq_schedutil.c | 15 +++++++++++++++
> 1 file changed, 15 insertions(+)
>
> diff --git a/kernel/sched/cpufreq_schedutil.c b/kernel/sched/cpufreq_schedutil.c
> index 7936f54..13f9cce 100644
> --- a/kernel/sched/cpufreq_schedutil.c
> +++ b/kernel/sched/cpufreq_schedutil.c
> @@ -260,6 +260,17 @@ static bool sugov_cpu_is_busy(struct sugov_cpu *sg_cpu)
> static inline bool sugov_cpu_is_busy(struct sugov_cpu *sg_cpu) { return false; }
> #endif /* CONFIG_NO_HZ_COMMON */
>
> +/*
> + * Make sugov_should_update_freq() ignore the rate limit when DL
> + * has increased the utilization.
> + */
> +static inline
> +void set_dl_rate_limit(struct sugov_cpu *sg_cpu, struct sugov_policy *sg_policy)

Maybe it could be renamed as ignore_dl_rate_limit() ? Lets see what others have
to say. But looks fine otherwise.

Acked-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>

--
viresh