Re: [PATCH v4 23/24] fpga: dfl: afu: add user afu sub feature support

From: Alan Tull
Date: Wed Mar 21 2018 - 19:51:43 EST


On Tue, Mar 20, 2018 at 2:10 AM, Wu Hao <hao.wu@xxxxxxxxx> wrote:

>> > +static int afu_mmap(struct file *filp, struct vm_area_struct *vma)
>> > +{
>> > + struct fpga_afu_region region;
>> > + struct platform_device *pdev = filp->private_data;
>> > + struct feature_platform_data *pdata = dev_get_platdata(&pdev->dev);
>> > + u64 size = vma->vm_end - vma->vm_start;
>> > + u64 offset;
>> > + int ret;
>> > +
>> > + if (!(vma->vm_flags & VM_SHARED))
>> > + return -EINVAL;
>> > +
>> > + offset = vma->vm_pgoff << PAGE_SHIFT;
>> > + ret = afu_get_region_by_offset(pdata, offset, size, &region);

Most of the functions here are afu_region_*, but there's also
afu_get_region_by_*. Better if afu_region_get_by_* to be consistent.

>> > + if (ret)
>> > + return ret;
>> > +
>> > + if (!(region.flags & FPGA_REGION_MMAP))
>>
>> FPGA_REGION_*? We already have FPGA regions which are something
>> different. Please call this something else.
>
> Yes, will replace it with DFL_FPGA_*.