Re: [PATCH v3 0/5] Support perf -vv

From: Ingo Molnar
Date: Thu Mar 29 2018 - 03:20:15 EST



* Jin Yao <yao.jin@xxxxxxxxxxxxxxx> wrote:

> For example:
>
> $ ./perf version --build-options
> or
> ./perf --version --build-options
> or
> ./perf -v --build-options
> or
> ./perf -vv

Thank you, the UI looks perfect to me!

> perf version 4.13.rc5.g4c1df1
> dwarf: [ on ]
> dwarf_getlocations: [ on ]
> glibc: [ on ]
> gtk2: [ on ]
> libaudit: [ OFF ]
> libbfd: [ on ]
> libelf: [ on ]
> libnuma: [ on ]
> numa_num_possible_cpus: [ on ]
> libperl: [ on ]
> libpython: [ on ]
> libslang: [ on ]
> libcrypto: [ on ]
> libunwind: [ on ]
> libdw-dwarf-unwind: [ on ]
> zlib: [ on ]
> lzma: [ on ]
> get_cpuid: [ on ]
> bpf: [ on ]

... and it's a nice touch that this is now printed in color, like the perf build
system does.

BTW., perhaps it would be nice to also print the macro name that is used within
the sources:

dwarf: [ on ] # HAVE_DWARF_SUPPORT
dwarf_getlocations: [ on ] # HAVE_DWARF_GETLOCATIONS
glibc: [ on ] # HAVE_GLIBC_SUPPORT
gtk2: [ on ] # HAVE_GTK2_SUPPORT
libaudit: [ OFF ] # HAVE_LIBAUDIT_SUPPORT
...

?

That would make it easier to grep around in the source looking for where code
related a particular features is located.

BTW. #2: to the compulsive perfectionist in me "HAVE_DWARF_GETLOCATIONS" is now
sticking out like a sore thumb: it's the only library flag left that doesn't have
the _SUPPORT suffix. Rename it to HAVE_DWARF_GETLOCATIONS_SUPPORT perhaps?

Thanks,

Ingo