[PATCH 70/72] staging: ks7010: Rename ks_wlan_set_multicast_list()

From: Quytelda Kahja
Date: Fri Mar 30 2018 - 03:11:23 EST


All of the net_device_ops callbacks are named after their counterparts
in the kernel's 'struct net_device_ops', except
ks_wlan_set_multicast_list(). Rename it to ks_wlan_set_rx_mode() for
greater consistency.

Signed-off-by: Quytelda Kahja <quytelda@xxxxxxxxxxx>
---
drivers/staging/ks7010/ks_wlan_net.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/ks7010/ks_wlan_net.c b/drivers/staging/ks7010/ks_wlan_net.c
index 29dd07cdd69d..e98f6163e724 100644
--- a/drivers/staging/ks7010/ks_wlan_net.c
+++ b/drivers/staging/ks7010/ks_wlan_net.c
@@ -72,7 +72,7 @@ static const struct iw_handler_def ks_wlan_handler_def;
static int ks_wlan_open(struct net_device *dev);
static int ks_wlan_close(struct net_device *dev);
static int ks_wlan_start_xmit(struct sk_buff *skb, struct net_device *dev);
-static void ks_wlan_set_multicast_list(struct net_device *dev);
+static void ks_wlan_set_rx_mode(struct net_device *dev);
static int ks_wlan_set_mac_address(struct net_device *dev, void *addr);
static int ks_wlan_netdev_ioctl(struct net_device *dev, struct ifreq *rq,
int cmd);
@@ -2817,7 +2817,7 @@ void send_packet_complete(struct ks_wlan_private *priv, struct sk_buff *skb)
* This routine is not state sensitive and need not be SMP locked.
*/
static
-void ks_wlan_set_multicast_list(struct net_device *dev)
+void ks_wlan_set_rx_mode(struct net_device *dev)
{
struct ks_wlan_private *priv = netdev_priv(dev);

@@ -2861,7 +2861,7 @@ static const struct net_device_ops ks_wlan_netdev_ops = {
.ndo_open = ks_wlan_open,
.ndo_stop = ks_wlan_close,
.ndo_start_xmit = ks_wlan_start_xmit,
- .ndo_set_rx_mode = ks_wlan_set_multicast_list,
+ .ndo_set_rx_mode = ks_wlan_set_rx_mode,
.ndo_set_mac_address = ks_wlan_set_mac_address,
.ndo_do_ioctl = ks_wlan_netdev_ioctl,
.ndo_tx_timeout = ks_wlan_tx_timeout,
--
2.16.3