Re: [PATCH] jffs2: safely remove obsolete dirent from the f->dents list

From: yuyufen
Date: Fri May 04 2018 - 04:07:23 EST



On 2018/4/28 6:22, David Woodhouse wrote:
This looks a lot better than the first iteration; thank you for getting
it to this point. One last thing, I hope...
On Thu, 2018-03-29 at 20:00 +0800, Yufen Yu wrote:
--- a/fs/jffs2/jffs2_fs_i.h
+++ b/fs/jffs2/jffs2_fs_i.h
@@ -42,6 +42,12 @@ struct jffs2_inode_info {
/* Directory entries */
struct jffs2_full_dirent *dents;
+ /* Directory open refcount */
+ atomic_t nr_dir_opening;
+
+ /* obsolete dirent count in the list of 'dents' */
+ unsigned int obsolete_count;
+
/* The target path if this is the inode of a symlink */
unsigned char *target;
You've made JFFS2_INVALID_LIMIT 64, which is reasonable enough
(although it's a bit of a weird name and possibly wants to be more
specific â invalid *what*?).
Thansk a lot for your suggestions.

Yes, it is really a bad name. How about JFFS2_OBS_DIRENT_LIMIT? I am not sure.


So the maximum interesting value of ->obsolete_count is 64. Which means
it might as well be a uint8_t and sit in the padding after the
'usercompr' field.

It might be useful to look at putting the mutually exclusive fields in
struct jffs2_inode_info into a union, and then we don't need the
additional space of the atomic_t either; we'll never need that *and*
the fragtree at the same time... will we?
You are right, thanks. But, obsolete_count may be large. So, I apply to use uint16_t and
it also sits in the padding after the 'usercompr' field.

Thanks,
Yufen