Re: [RFC PATCH v4 2/3] acpi: apei: Rename ghes_severity() to ghes_cper_severity()
From: Alex G.
Date: Fri May 11 2018 - 11:45:58 EST
On 05/11/2018 10:39 AM, Borislav Petkov wrote:
> On Mon, Apr 30, 2018 at 04:33:51PM -0500, Alexandru Gagniuc wrote:
>> ghes_severity() is a misnomer in this case, as it implies the severity
>> of the entire GHES structure. Instead, it maps one CPER value to a
>> monotonically increasing number.
> ... as opposed to CPER severity which is something else or what is this
> formulation trying to express?
CPER madness goes like this:
0 - Recoverable
1 - Fatal
2 - Corrected
3 - None
As you can see, the numbering was created by crackmonkeys. GHES_* is an
internal enum that goes up in order of severity, as you'd expect.
If you're confused, you're not alone. I've seen several commit messages
that get this terminology wrong.