Re: [PATCHv2 00/16] atomics: API cleanups

From: Mark Rutland
Date: Wed May 30 2018 - 07:23:26 EST


On Tue, May 29, 2018 at 04:43:30PM +0100, Mark Rutland wrote:
> This series contains a few cleanups of the atomic API, fixing
> inconsistencies between atomic_* and atomic64_*, and minimizing
> repetition in arch code. This is nicer for arch code, and the improved
> regularity will help when generating the atomic headers in future.

> Mark Rutland (16):
> atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/
> atomics/treewide: remove redundant atomic_inc_not_zero() definitions
> atomics/treewide: make atomic64_inc_not_zero() optional
> atomics/treewide: make atomic_fetch_add_unless() optional
> atomics: prepare for atomic64_fetch_add_unless()
> atomics/generic: define atomic64_fetch_add_unless()
> atomics/alpha: define atomic64_fetch_add_unless()
> atomics/arc: define atomic64_fetch_add_unless()
> atomics/arm: define atomic64_fetch_add_unless()
> atomics/powerpc: define atomic64_fetch_add_unless()
> atomics/riscv: define atomic64_fetch_add_unless()
> atomics/treewide: make atomic64_fetch_add_unless() optional
> atomics/treewide: make test ops optional
> atomics/treewide: remove atomic_inc_not_zero_hint()
> atomics/treewide: make unconditional inc/dec ops optional
> atomics/treewide: make conditional inc/dec ops optional

While testing the subsqeuent generated header patches, I discovered that
the andnot ifdeffery was inconsistent to that for all other atomics, so
I'm going to append the below patch to this series, if it needs a v3.

Otherwise, that's pushed out to my atomics/api-cleanup branch.

Thanks,
Mark,

---->8----